---
title: "Release Notes 4.1.6"
canonical: "https://support.soutron.net/space/RN/2523289/Release%20Notes%204.1.6"
format: markdown
---
Important: New Licence key is required as of 4.1.4 A Licence file must be obtained prior to upgrading if Soutron is self-hosted. Soutron hosted clients will have the licence updated at time of upgrade automatically. Important: As of 4.1.5 IE11 will no longer be supported. Due to limitations within older browsers IE11 will no longer be actively supported when using Soutron applications. The software will continue to be accessible via IE11 but Soutron will not actively fix known issues found with this version of web browser instead we recommend the use of Chrome, Firefox, Safari or Microsoft Edge instead. Important: API Changes With the introduction of a feature rich API in 4.1.5 we will no longer add additional functionality or improvements to the old web service API. This will continue to be supported for a further two years as of the 4.1.5 release date for critical bug fixes only. It is strongly advised you make plans to switch to our new API as soon as possible.  Important: Content & Location filters are no longer supported above the search results table. This is due to the macros being merged within the facet search filters macro which must be placed on either side of the results table. Important: Locations (copy management) menu in the library application has been renamed to Manage Items. This is part of our ongoing plan to standardise wording and terminology as we re-engineer the application.   Optional Customer Actions: Configure facet search filter macro. This can be done by editing the default macro located under  System & database settings > Database settings > Faceted Search Templates  in the admin application. Add the PDF viewer macro (  [FILE_VIEWER]  ) to your  Record View page body template.  Version 4.1.6 (37) Release Date October 2021 Please remember to clear your browser cache before using the system after the upgrade,  see here for more information. New Feature      LMS-1817 Facet filtering of search results. LMS-5327 Embedded PDF Viewer for documents stored in Soutron. LMS-5503 It's now possible to change the name of Submitted documents. LMS-5735 First phase of new catalogue entry form, with ability to switch between new and old interface for record editing. LMS-5875 Submitters can now upload new versions during review step. LMS-5877 New email notification for delegator for a review once marked as complete.  LMS-5878 Added email notification settings option to My account (Currently only used for submission notifications). LMS-5938 Validation list maintenance has been migrated to the Admin application. LMS-5941 It is now possible to access validation list settings from the field settings page. LMS-5942 It is now possible to configure linked validation lists where child list values are dependant on the parent value selected. LMS-6079 Added JavaScript enumerations download file for 3rd Party developers using API. LMS-6032 New rich text editor is now used throughout the Admin and Portal parts of the system. LMS-6039 The New Loan page in Admin application now shows an alert during loan process if users notes field contains data. LMS-6096 Entries in a validation list can now be set as record type specific. Improvement LMS-910 It is now possible to delete entries from a validation list even if it is used by records. Doing so will remove the value from records. You will be prompted to enter a username for confirmation of the action. LMS-5501 Reviewer delegation can now be assigned to an existing Informed User. LMS-5811 Using facet filters you can now exclude records with no copies from Portal results. LMS-5864 New pending publication workflow status for EUS. LMS-5865 Submission  EUSRecordTable  now shows all applicable fields in table. LMS-5871 The Submission OOO task is now disabled by default. LMS-5881 Improvements to final document functionality. LMS-5898 Assigning admin user to EUS Admin notification. LMS-5903 Send Requests now show address as hover in request maintenance. LMS-5926 Enable Expression override in submission metadata page. LMS-5931 Portal and Admin applications changed to use  Roboto font by default. LMS-5933 EUS reviews table in My Account - Active Reviews. LMS-5934 Copy Notes can now be displayed in the Portal copy grid (for roled users only). LMS-5936 ASP.NET info has been removed from server response headers. LMS-5943 Submission record statuses have been added as resource strings. LMS-5946 Portal & Admin toast notifications now display for longer. LMS-5949 Submission notifications now send via the portal the submission belongs to, ensuring links are intact. LMS-5960 Ability to change book to view request date and loan date on the active/awaiting collection tabs respectively. LMS-5962 Ability to change request priority and cancel if admin is not in the controlling office. LMS-5974 New resource string entry for when submission document  is too large. LMS-5975 New Resource String entry for black reviewer comments processed button pop up. LMS-5979 My account: Renew function button improvements. LMS-5980 Syndetics   Unbound record sync now only includes published and non-deleted records. (SP updated) LMS-5981 API now correctly shows the loan due date and copy status when using the copies method. LMS-5983 Added portal request address and phone translations. LMS-5986 It is now possible to edit the received date in Check in receipts. LMS-6003 Improvements to field and record type maintenance where field localisations have been applied. LMS-6010 Overdue notices are now based on the day rather than specific time of issue. LMS-6012 Submission: Inform user can now check-out documents if the option is enabled. LMS-6013 Prevent Document from being added to the "File" field when status changes to "Pending external publication". LMS-6017 New option to allow two submission notifications to be always Cc'd to one or more email addresses. LMS-6018 Portal Results: Image pop-up quality improvements. LMS-6022 Unpublished records now redirect to not found page if the current user does not have access. LMS-6023 Mandatory fields can now be set for submission & standard records independently. LMS-6031 No records found message text updated. LMS-6033 Inactive record types no longer display in Submission create menu. LMS-6041 Improvements to file permission verification during download. LMS-6076 Collections menu in library application now redirects to collections page in the portal application. LMS-6077 New resource string for informational message when a reviewer who is also a rolled user is approving submissions. LMS-6078 Submission document version table now only shows if image or file type fields are included in the record type. LMS-6095 Performance improvements to combined word & relevance rank calculation tasks. LMS-6055 CORS headers can now be set for the API when developers are using cross domain resources. Bug Fixes LMS-5240 Content and record type filter error on search results. LMS-5374 Title search not working in My Account > My Submissions. LMS-5392 Images added to submission rich text fields can now be re-sized. LMS-5588 Assigning subject terms in one field based on mapping of another. LMS-5616 Admin application now shows diagnostic information via 'i' icon in page footer. LMS-5676 Upgraded application to latest .NET core. LMS-5775 Portal search now correctly excludes issue records unless the toggle is selected on the advanced search. LMS-5840 Non-Public field available to guest user. LMS-5873 Cancel multiple requests - page refresh issue. LMS-5900 Enquire function error when assigning Portal Resource String. LMS-5902 Cannot complete request due to address errors. LMS-5910 Submission notifications failed to send unless SSL is disabled. LMS-5911 Searching for users in EUS is not working for Non roled users. LMS-5912 Submission emails not being sent in language of portal being used. LMS-5914 Edit link function in EUS notifications now works. LMS-5915 Key value is no longer overwritten when multi entry during document imports. LMS-5916 Clicking a file uploaded to invoice opens on top of application. LMS-5918 Line break added to EUS metadata is generating error. LMS-5919 Expiry submissions email were being sent every 5 minutes. LMS-5922 Date localisation LMS after selecting from date field. LMS-5923 URLs not working in rich text field in submission. LMS-5924 Roled user is not seeing all fields in submission page despite function being enabled. LMS-5925 Providing default option for rich text field in new EUS metadata to show source by default. LMS-5927 Portal record tree loading/active node issue. LMS-5929 Clicking on a PDF in EUS view mode is opening on top of the application. LMS-5935 Basic EUS Licence - Problems saving metadata have been fixed. LMS-5937 Data entered into rich text field is now correctly saved. LMS-5939 Invoice preview was showing whole sub period not date period paid. LMS-5940 Costs description field not saving in a subscription order line. LMS-5945 Intermittent problems accessing submissions for end users. LMS-5948 End user can edit a submission metadata when status is approval workflow finished for a basic submission. LMS-5950 Reviewers lose access to submission when status is new external publication. LMS-5951 Removing text from resource strings from a specific portal or language generates red error. LMS-5952 Saving a submission when status is pending external publication is generating red error. LMS-5953 Uploading more than one document into a submission generates red error. LMS-5954 Book covers not returning on portal results page. LMS-5955 Fixed a few issues with portal password reset. LMS-5956 Unapproving a submission where pending external publication is enabled. LMS-5957 Red error when user tries to drop in two docs when only one doc exists when awaiting submitter review. LMS-5959 Admin gets error about no documents in mandatory field when status is awaiting admin approval. LMS-5961 Cannot export validation list values via XML export report. LMS-5963 Advanced search returns no records if the default search field template is changed or removed. LMS-5966 Fixed an issue with 'Show local office only' option for rolled users. LMS-5967 User search suggestion not working in EUS. LMS-5968 Logging out of portal generates an error. LMS-5972 Reviewer cannot edit metadata as still locked to submitter. LMS-5973 Cannot edit a comment in a submission. LMS-5982 Fixed a problem when removing related terms from thesauri. LMS-5984 Reactivate request doesn't move it to active requests. LMS-5987 Citation Field in search results not clickable. LMS-5988 Check-in documents text - add to resource strings and change text. LMS-5989 Pop-up comment box appears when clicking black process comment when comment has been added. LMS-5990 Error when deleting a submission. LMS-5991 Error when clicking on Google preview icon in Portal. LMS-5992 Administrators cannot override and approve a submission where status is awaiting review. LMS-5995 Request sending/collecting option is now correctly enabled/disabled based on Portal settings. LMS-5997 Notification to submitter not being sent when last reviewer has approved AND when administrator approves & other notification problems. LMS-5998 Expiry date of submission was not being correctly set. LMS-5999 OfficeID not stored when deleting a copy record. Affected reporting capabilities. LMS-6000 Tree not loading correct record after initial loading. LMS-6001 Self Issue - is returning users who have left. LMS-6002 New Pop up message for when user partially checks out documents. LMS-6004 Unreceiving an issue that has transactions on it is not removing it from catalogue record. LMS-6008 New rich text field in submissions - not allowing text mask on URL entered. LMS-6016 Editing issues on check-in is not updating catalogue expected Issue table. LMS-6019 Amendment of a submission report. LMS-6024 Delegated submitter cannot finish review. LMS-6025 Copy table now correctly shows in order preview. LMS-6026 Portal sorting not working correctly. LMS-6037 Pop up not appearing for submitter or delegated submitter when have not downloaded document for processing reviewing comments. LMS-6040 Collections widget was showing incorrect icons to guest users. LMS-6044 Resolved an error when performing global edits on a globalized field. LMS-6047 Roled user who is assigned as a reviewer cannot change another user to Inform. LMS-6048 Fixed a problem with amend search pop-up not retaining values. LMS-6054 Problem with tree view in portal loading correct record in context. LMS-6058 Resolved an issue when paying an invoice which has a cost less than the order value. LMS-6059 Removed invalid gif image reference in portal. LMS-6061 Sublocation is now correctly sorted when used in report parameters. LMS-6063 Corrected invalid parameters used in API suggest calls via portal & admin applications. LMS-6064 Fixed single record result issue when used via API. LMS-6066 Field type is now correctly set when copying a record type. LMS-6070 Fixed an issue preventing admins from unapproving submissions. LMS-6081 Fixed the date filter in My account: search history. LMS-6084 Corrected some field specific settings where see-also can/cannot be used. LMS-6087 Top level terms now correctly display when they are also added to a category. LMS-6091 Saved searches now correctly only return published records when created via the portal. LMS-6101 Several fixes to amend search and save search displays when saving a search.